Nucleus periodically losing connection

I have had my Nucleus up and running now for about 4 days. It has been working perfectly…until today. While listening this afternoon the music stopped and a message popped up that I had lost connection to the Core. I waited a while and it was eventually re-connected. About an hour later the same thing happened. When it asked if I wanted to change Core I said yes and it took me to a screen displaying my iMac which I was previously using showing ready and the Roon core was shown as “initializing”. I assume this means it rebooted. I never had these issues when the core was on my iMac. #support

Sounds like you have an issue with device discovery. This is known to happen using Linux based cores which the Nucleus is Android and iOS app. What is your endpoint iPad or phone or something else? Killing the app and restarting often clears this issue or some it works only by rebooting the core. It seems to be related to certain network configs as some have it others don’t. Your best posting your full network layout and types of switches routers etc and endpoints to help support help you.

Thank you for your help. I am using an Apple Airport Time Capsule as my router. (Not streaming from the Time Capsule). I have a Synology NAS. Other devices hardwired to the router include the Nucleus, a Lumin Streamer/Dac and an access point in an out building. I also have a D-Link switch in my music room connecting the Nucleus and the Lumin player. I am controlling roon from a MacBook Pro laptop and alternately an iPad. I have two roon zones. The one in my main system includes the Lumin (hardwired to the router) and the other zone includes a Bluesound Node2 that streams wirelessly from the access point I mentioned above. If you need additional information please advise. thanks again.

So has the issue with stopping playback been on both endpoints or just one in particular?

Just on my main system (Lumin). I have only rarely and for only very short periods listened to the other endpoint so I don’t have any idea if it is involved with the core disconnect. It has only happened twice and both times I was listening through the Lumin player…and the two disconnects were about an hour or so apart.

I would start by first powercycling your network gear so turn off you lumin and Bluesound, router and switch leave off for a 30 secs or so then bring on the router then any switches and devices after router has fully started. Check your network cables are all fully inserted. Then see if you get it again. Also be good to check that all devices including nucleus are in the same ip range and subnet.

If you still get issues then it’s worth trying to eleminate network cable or device issues. So try switching the network cable from the Lumin to switch to see if that remedies it. If not try and bypass the switch altogether and connect directly to the router so bypass the switch. If you still get issues then try a cable direct to router outside of the normal wired in cable, I know this but may not be easy to achieve. If still happening then might be your router. I don’t know anything about apple gear so I will leave this to others that might.

Hey @Randy_Hatcher — Thanks for reaching out!

As Simon mentioned above, rebooting everything is definitely a great first step here.

I also wanted to mention that, as mentioned in our networking guide, we’ve previously seen networking issues related to Apple network hardware like the Airport Time Capsule. It’s hard to say if that’s what’s causing the behavior you’ve seen here, but we do like to give people a “heads up” when they’re using this kind of hardware.

Can you provide some additional information about the Switch that is in use in the music room? What is the model? Is it a managed switch?


Thank you for your response. The brand of the switch is t-link. The model of the switch is TL-SG1008D. I don’t know if it is a managed switch…not sure what that means. I think it’s a pretty basic unit. It was plug and play…no configuration was necessary. Regarding the router. I do understand that the Apple routers are not favored by roon…,but for now that is what I have. If it proves to be the bottleneck in my network I am not opposed to replacing it.

Thanks for the info, @Randy_Hatcher.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Thank you Dylan. If/when this occurs again I will contact you and provide the information you requested.

1 Like

Happened just now…approx 1:40pm CST, Sunday, Aug. 26. Connection has been dropped now for about 5 min…has yet to reconnect on it’s own.

it also happened about 3:00pm and again 15 min later.

Thanks, @Randy_Hatcher!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Had another loss of the core about 8:00am yesterday. Lost it for about 5 min then it reconnected. Everything working fine now.

Hmm. I also have seen this problem with my Nucleus+. It happens way less frequently to me – I might get it one day and then not have another one for a couple weeks. It also doesn’t appear to be tied to any particular zone I’m playing as it has happened when playing music in multiple zones. I was waiting to see if I could try to find a way to reproduce it more regularly before saying anything but have not been successful. But since @Randy_Hatcher is raising this issue now thought I’d raise my hand also.

@dylan – what should I do to help on this? Since you’ll probably ask – here’s my fairly complicated networking setup but it is all enterprise equipment and very solid:

Hey @Randy_Hatcher,

I just wanted to let you know that the team is currently investigating this further and attempting to reproduce the behavior that you’re seeing in-house. I’ll be sure to update you as soon as I receive an update from the team.


The next time this behavior occurs can you let me know the timestamp? Once you’ve done so I will enable some diagnostics on your account and pass them along to the team.


You bet. Stay tuned. Thanks for the help!

1 Like

A post was split to a new topic: Connection to Core lost, showing “initializing”

Lost connection again just a few min. ago. (about 6:51PM CST). Connection restored after about 5 min.

A post was split to a new topic: ROCK Core lost connection to endpoints