Remote unable to connect to Roon core when VPN is used on Core

Core Machine (Operating system/System info/Roon build number)
Windows 10 home PC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Tilgin AB HG2284a router via Ethernet cable.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue

When I first installed Roon, remote on my Android phone was connecting without any problems, with VPN and anti virus active on the PC. Now I can’t connect.

I done troubleshooting as described on the relevant page, without success. When anti virus and VPN are active, the remote doesn’t see the core at all.

When both are disabled, it see the core and trying to connect, with no success. Same thing when I try with my Lenovo tablet.

Accept connections from remote is active. Both core and Android phone are on the same network. Attached screenshots of failed connection.

You’ll need to turn off the VPN so the app can discover your core.

I have stated that I already did that. Only when they are off, the app try to connect, but doesn’t succeed, as shown in picture no 3. When both are on, the app doesn’t see the core at all, as shown in picture
no. 2.

I’ve heard others say that they can’t get Roon to work when running a VPN. I use ExpressVPN and have had it running on both the Mac that runs my Core, and the phone that runs the Roon app, and it all worked fine. I’m afraid that probably doesn’t help you one bit, but at least it shows that it can work. Good luck.

Thank you Chris. I’m using ExpressVPN as well, and I know it can work with Roon remote.
What troubles me the most is that spending 500 $ just a couple of months ago, doesn’t intitle me to a decent customer support. Only a half assed one response, that doesn’t really help. To me this is very disappointing

I’ve moved the thread to #support so it gets appropriate attention.

You need to help others to help yourself. What you think may be clear isn’t necessary clear to someone who’s not sitting in your home. So please answer questions with a little more grace.

I did answer and clarify the situation I’m dealing with, in a correct tone, but didn’t get any response from you.
Bear in mind that all the relevant data was in my first post. I feel it was not read through and the response was off hand. First you give irrelevant answer, then you ignore my follow up, and now you scolding me. That is one great customer service. Cheers.

This is a community site and I am a volunteer. Goodbye.

You are actually talking down to a fellow forum member, someone who just wanted to help. He is not from Roon support. Actually Roon have not answered you yet. If you are frustrated, you should vent with actual Roon people who got your money and should help you.

Roon support will be along to help at some point.
Have you rebooted everything since disabling the VPN and firewalls, including the router?

Hello @Ziggi_Fuxman,

A) Have you had the VPN software installed on your computer for as long as you have been running Roon on it?

B) Are you able to get the Android device to connect to your Roon Core at all?

C) Ensure that you do not have any firewall software enabled on your computer. This includes the Windows Firewall as well as any firewall functionality included in an Antivirus program.


A) yes
B) no
C) I have disabled the anti virus and Windows firewall. As I mentioned above, only with anti virus and firewall disabled, the remote is trying to connect, with no success. When they enabled, the remote doesn’t see the core at all, like in the screenshots above.

Hello @Ziggi_Fuxman,

Thanks for sharing those additional details. I have a few thoughts starting out:

  1. Where exactly is the VPN being installed in the chain? Is it on your Core PC, the Roon Remotes or on a Router level?

  2. Can you please explicitly re-add Roon.exe and RAATServer.exe to your Windows Firewall? I have sometimes seen Windows Updates revert firewall settings and I would like to make sure these exceptions are in place moving forward. Roon.exe / RAATServer.exe can be found by navigating to the Database Location /Application folder path and you can use these instructions to add them to your Windows Firewall.

  3. To ensure that everything is in a fresh state, have you tried rebooting both Core and Network yet? I would give this a try. Also, is the behavior the same if you disable the VPN and then reboot your Core?

We have a few staff members who mentioned using VPNs with Roon in the past. This is not something we can guarantee to work, but it should not cause such issues of being unable to connect if you are still on the same WiFi network and if the VPN has been disabled.

Please let me know if any of the above suggestions trigger a change in behavior. Thanks!

Hi noris.
The vpn is on the core pc. Bear in mind that I am not using it at all when trying to connect with remote, so IMO, this should not be a factor here.
Windows firewall is active only when anti virus is disabled. When I try to connect with remote, I disable the anti virus , and firewall kicks in.
I have added now the the apps you mentioned to “allowed apps” in firewall settings.
I have rebooted the core pc and router, but nothing has changed. Still can’t connect.
I will mention again that disabling vpn is not an issue for me. So no need to take in consideration, but disabling anti virus is not acceptable at all in the long run, only in troubleshooting process.
Thank you

Hello @Ziggi_Fuxman,

Thank you for clarifying this. So it appears that the issue may not be related to the VPN, unless possibly the VPN changed part of the network on the machine with a driver. Was the remote working until right before installing the VPN?

I understand, and once we find the issue we can add exceptions. Can you please try to temporarily disable the antivirus and let me know if there is any change with the issue?

Also, I would like to take a look at this aspect:

Can you please confirm that multicast is enabled in your router settings? Making sure that multicast is passing properly is essential for Roon to operate. I have found a similar model router which displays multicast settings as shown here, can you verify if you have such options on your end?

VPN was installed before room.
I have disabled anti virus, with no change

Apparently I gave you wrong router name. My apologies. The Tiglin is a DECT/CAT-iq device.
The correct router name is VETCH 605

Hi @Ziggi_Fuxman,

I tried to look up the VETCH 605 but I could not find any documentation for this router.

I’m not sure what kind of router this is and what the default multicast settings are for it, but I would suggest swapping out this router with a standard consumer-grade router from a well known company to see if this changes anything with regards to the issue.

If you don’t have another router handy, the other option here would be to bring your PC and Roon remote to a friend or family member’s house and verify what the behavior is there and rule out this aspect.

As before, I would suggest verifying the issue still occurs with the antivirus temporarily turned off on the other network to eliminate this as a possible issue source.

Can you please let me know if this is possible?

Open up a command prompt and inspect the output of the commands …

  1. ipconfig /all
  2. route print

might shed some light about what’s going on here.

Thanks for your suggestions
I will try them and let you know the results

1 Like