Roon losing core

Hello @support.
I have my library on a Synology DS716+ II, RoonServer on a Win10 laptop, both hard wired.
Roon remote is on an ipad mini, which is only used for Roon, nothing else.
Player is Lumin U1.

Occasionally, Roon cannot find the core, but I always managed to get it working again.

Today, it tells me that the storage location seems to be off line.In the storage setting, it says the disk is not available at [Roonserver Name] Music, where it did always work. Looking at this folder, it is empty. So I thought I may have deleted the database, so now I am putting back a backup from a few days ago. takes very long, few hours it seems.
I hope you know how I can get it working again.


Am I really the only one having this problem?

Hi @Arie_Bos — Thank you for your detailed report!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Additionally, can you please confirm the following:

  • Have you tried rebooting your Core, Synology, and any applicable networking hardware?
  • Can you please share a screenshot from Roon of Settings > Storage?
  • Are there any active antivirus or firewalls on the Core machine?

Thank you!

Hi Dylan,

Thank you for the response.

Here goes:

network: CAT6
router: Ubiquity Edgerouter X
switch: HP Procurve 1810 G24
Wireless (for remote): Ubiqity
topology: star based from switch
Roon Server: Asus laptop, i7, 4gb Ram, 500gb SSD, Win10
Remote: Ipad mini (latest version)
Library: Synology DS716+II, 2gb Ram, 2 disks 3TB in raid (WD30EFRX-68EUZN0)

I have rebooted all elements above, but the remote can see the server (‘MOBILEARIE’) but not the core database.
I did a backup restore last night, took about 5 hours, but the folder shown in the image (MOBILEARIE > Music) is still empty
On the Server (Asus) no firewalls, not antivirus, only Malwarebytes, but that never caused any problem when it was working well for the last 6 months, although I always thought this set-up to be slow: response time for any action from the remote was about 3-4 seconds.

Thanks again,

Thank you for the setup details, @Arie_Bos.

Just to verify, your iPad remote device is able to connect to the Core, but your Core is not able to access the files stored on your Synology, correct?

Moving forward, I would like to propose some tests for helping us narrow down the root cause of this behavior:

  • Disabling the your storage location(s) in Roon and then re-enabling them.
  • Try connecting your Core and Synology directly to the router, removing the switch from the equation.
  • Can you please verify that Roon is up to date on your Core and remote device? Please also verify that your Synology is up to date.

Thank you,

@Arie_Bos So when did this stop working? was it after the 1.5 update?

Does your NAS have fixed or DHCP address…if you use the IP then try to edit the share to use that instead of the device name. If that works then I suggest you use try to make it fixed IP and stick with that.

I see you are using an EdgeRouterX (great little box btw) and Unifi AP so you should be able to negotiate your way around fixing an IP address :stuck_out_tongue:

Hi Dylan,

I am not sure if the core can see the NAS, as the roon server has no interface. As you can see in the screenclip, the ipad does see the server, but it seems to me the database is simply missing.

  1. Dis/re-abling the path to MOBILEARIE did not make a difference. Then I deleted the MOBILEARIE path and re-added it. the ipad immediately began scanning files. After a while, some albums are showing up, so I guess that does the trick. As I write this, it is still scanning, but it seems to me that the database is being build as new, so I lost all information from the previous one? Once the database building process is finished, I may try to restore a backup from a few days ago.
  2. It is physically rather difficult to move Synology and server to the router.
  3. all devices are kept up to date. I do not know if roon server must be updated, as there is nothing where you can see that, I think.

@wizardofoz, It only happened 2-3 days ago. and I think the 1.5 update was from 10 days ago, or so. So I guess it is not the update.
not sure if the NAS is fixed or dhcp. fixed seems more logical, but I don’t know where to check that on the synology.


@Arie_Bos with an APP like Fing or Net Analyzer you should be able to see the NAS from the iPad or ping it from the PC in the command prompt.

In the network settings you should either have DHCP or a fixed address.

Not yet solved, I think, as it stopped with 1530 tracks only. Rescanning did not find more ( must be around 12,000 titles)

Based on the shot above your NAS is not being used…its scanning the local PC disk

What version of DSM is the NAS running … latest should be something like 6.1.6

I just realized that… But I don’t know where the core database is stored

It doesnt matter about the core database for now…Roon will know where that is…its the Music location you need to have correct. Mine looks like this - the “music” name is case sensitive too - yours might be different


it is version 6.1.6-15266 Update 1

Yes indeed, Mine always was \\MOBILEARIE\music, but if I look in that folder, it is empty. So I think the database is just acidentally deleted or so. Strange however that I tried to restore a back-up twice and still nothing shows up

what about when you use the file browser in the Synology web GUI?

To music library on the NAS can be seen with Synology file station, but also perfectly with window machines ( as always was the case). So it is all there, just no database on the roon server PC, but is has access to the library on the NAS

What about the NAS settings for SMB sharing?

Oh… O copied your settings above, but I do not really know how this works…
I always use ip address to approach the NAS.

Thanks for the additional information, @Arie_Bos!

In reviewing your responses here, I just wanted to clear up what may be a point of confusion. Based on your report, I do not believe that your data base was deleted as you mentioned above.

While you may not be seeing your library, you should see that your playlists and tags still exist Roon, and those come from your Roon database. It sounds like the problem here is the connection from your Synology, where your library files are stored, to your Roon Core machine.

If I am not mistaken the HP Procurve 1810 G24 is a managed switch.

I usually like to mention that we’ve tracked a number of issues to in the past to managed switches(examples: here, here, and here).

The simplest way to confirm whether the switch (or its settings) are contributing to these symptoms would be to temporarily test with the switch removed from your network. Whether things improve or not, the results of that test would be a great data point. I know you mentioned it’s not ideal to perform this test, but it would certainly help with narrowing down the possible root cause here.

I would also recommend enabling flow control on the switch, as we have seen that settings resolve a number of issues for other users in the past.