Roon not starting Windows 10

How about Roon core not running on my Windows 10 PC after putting el cap on my Mac in my office?

I do run Roon remote from my Mac but the core is on my Windows 10 touchscreen PC.


Hello @cmr600, thank you for the report and sorry for the inconveniences, it seems like you have a problem with connection between Remote client and Server. Can you please give a clearer explanation of what exactly is happening ( feel free to use this FAQ topic as a guide ).



I have a dedicated Lenovo a740 touch screen pc running Roon, pointing at my files on my QNAP. That connects to my Meridian ID41 through my DSP’s.

Occasionally, I fire up my Mac in my office with Roon remote pointing to that set up.

As of yesterday, Roon opens, shows the black screen with the moving white circle icon in the centre, and just keeps “processing” as if it’s booting up. Eventually after about a minute or two, it shuts down Roon.

I don’t have anything else on the PC, it’s just dedicated to Roon. Only thing I did yesterday was update my Mac to El Capitan but I don’t see how that would be an issue (it’s only the remote accessing the PC).

Make sense??

Actually this seems to be nothing to do with El Cap and all to do with PC…

OK update,

I moved back to Windows 8.1 to see if that was an issue, and while I could get the Roon app to fire up, the graphics on all the text was little black blocks. This would suggest (thanks Russ) that there was a graphics driver issue …

So, with the Roon app opening up again I re-upgraded back to Windows 10.

Now - the Roon app opens up eventually, but I’d say the boot up time is around 90 seconds… The graphics are back in place.

However - the scanning and updating “whirly wheel” on the top right of the screen is still spinning, even though the library was fully imported some time ago. It’s gone back to Adding Music to Library which I thought it had finished ages ago.

Worst still, I can now browse, select, drill down and play, but the playing of any music to my ID41 and M system lasts about 5 to 20 seconds before audio stops. The Roon app still looks as though it’s playing (it has a pause button not a play button) but the music playback stops. Checking another track and clicking play results in nothing.

Currently it’s playing - but having has Sooloos for the last few years I’m certainly not enjoying the lack of stability…

Hello @cmr600, thanks for detailed response. Glad you were managed to sort out graphic issue by yourself.

90 sec loading time
When we are talking about loading time we need to take into consideration several aspects: hardware spec of your machine and Roon library size.
For 2-3 years old high-spec machine loading time of the library with 150-200k tracks should take around 90 seconds (based on my observations). You should also take into account your storage type - with SSD loading time will be shorter.
In any case to go further here I need a spec details of your machine and Roon library size information.

Our app also have a feature that can clean up stale data in your library database (as a result loading time can be decreased ) . Here is how you can use this feature:

  1. Launch Roon
  2. Go to Settings
  3. Open ‘Setup’ tab
  4. At the very bottom of the list press on ‘Clean up library’
  5. Mark the info you want to delete and press ‘Clean up library’ again.

Wheel at the upper right corner
You can get additional info regarding background processes which are currently happening by pressing on this spinning wheel (new popup will appear). If’ you can make a screenshot of this popup and paste it here we can figure out what exactly is happening.

Problems with ID41
We have heard complaints from other users regarding ID41. What ver. of firmware is installed on your ID41 ?

Hi there,

brand new i7 16GB 1TB SSD machine so it should be flying enough. Files are stored on a QNAP TS871 i7 16GB RAID drive, again it streams and transcodes 4k TV on the fly I think it should be OK on this :wink:

It’s a brand new build so not sure the database should need cleaning just yet, but I’ll try it.

As for the spinning progress wheel, that’s now stopped. Quick question, does it “re scan” the database every time the system reboots?? rescan even if it doesn’t reprocess? with 300,000+ tracks that would take a time…

Finally I’m on the latest firmware version for the ID41.

Thanks :smile:

Hello @cmr600, sorry for late response. You have a really good hardware :wink:

Usually app re-scans all folders which were set as a watched folders on every launch + it also does this after disabling/enabling folders. But this process is happening in the background, and you can use the app during scanning (it shouldn’t take much time even for 300k + tracks library)

Regarding ID41, let’s specify the exact ver. of the firmware.

Also, I’d like to see your logs. I’ll follow up with you over PM and provide with further instructions.

Thanks for your patience and sorry for inconveniences.


I’m having problems on my computer. Roon does not start on windows 10 at all.
I see the initial screen, the one with a quote, the I receive one message from windows saying that roon stopped working and needs to be closed.
Tried to uninstall roon completely but no improvement.
On other computers I have, running windows 8.1 everything is fine.


Hi nerone,

A new build has just been released today (Build 65) which may make a difference. I’d suggest uninstalling and downloading and installing the new build.

If you have any continuing issue, please feel free to post here or in a new Support thread and the devs will look into it further.

Thanks @andybob!
I think this is the version I used, because I tried again just some minutes ago.
But I will try one more time.

Hi again.
I just checked that I didn’t have the newest version, I had installed the Build 55.
I tried to download again from the website, but this is the only version I get, not the 65, can it be something wrong I’m doing?
On the other hand, I was able to make it work using compatibility mode for windows 8.

Hi nerone,
There may have been a delay in updating the website links:

Give it another shot :slight_smile:

Guys @nerone and @cmr600 are you still having your issues ? Your feedback will be appreciated.

I’ve been travelling and also trying to find my id41 firmware version so not home at the moment.

Another shot (with build 65): Definitely still having out of memory (32 bit) issues, preventing Roon from starting most of the time.
It “gets better” if I minimize the window during startup (… then Roon doesn’t use memory to render the user interface). Task manager showing >1,319 MB allocation.
Problem is that there is not enough memory for the UI left, so as soon as I restore Roon from the task bar, I get (this is since the first release I tried, build 51, then 55, now 65) either a white window with a red cross, or garbled “Klingon” text, or an immediate crash (or a combination thereof).

Hi @vova,
I updated to build 65 and it still crashes when I launch it. I have to use compatibility mode but even doing this it crashed at least one time that required me to restart the computer.
As soon as I have some spare time I’ll try to use diferent settings for compatibility mode and see if I can find the one that’s more stable.

I think I just found a solution.

I tried to run the roon.exe using the dedicated graphics processor, and it worked. Not sure about how long will it be working, but I’ll post here if I find any problems.

The computer with this problem is a Dell, with an i7-2670QM CPU with both an Intel integrated graphics 3000 and a nVidia GeForce GT540M.

Hello @nerone glad you were managed to sort it out. If the crashes continue ping me or mike and we’ll gather your logs to get more info.

I recently turned my PC into dual booting to take advantage of Audiophile Optimizer. Everything worked on original setup, howeverf when I attempt to start Roon on new (2nd) system it will not start. Just goes to spinning orb. Everything else is working, ie, HQPlayer, JRiver etc, Just Roon refusing to start. It did start intially, however when I went into setting re library, dac, hqplayer, etc, it would not start again. I have since uninstalled and reinstalled a new download without effect. Hoping you can assist.