Roon on ROCK crashes due to Linn devices with "CreateHandle: Assertion" error [Fixed in Roon build 1148]

Roon Core Machine

INTEL NUC10i7FNK, 32 GByte of RAM, 1 TByte SSD, Rock 1.0 Build 227, Roon 1.8 Build 884

Networking Gear & Setup Details

Router: FRITZ!Box 6591 Cable, GBit Switch: Netgear ProSAFE JGS524PE, Wifi: FRITZ!Repeater 3000 (connected via Ethernet to the Router)

Connected Audio Devices

LINN NG Klimax System Hub (KSH3), connected via Ethernet

Number of Tracks in Library

appr. 440.000, stored on QNAP TVS-671 with DTS and 16 GByte of RAM; there are 6 x 6 TByte (WD red plus) disks in RAID-1 where the music is stored, mounted to the NUC/Rock via SMB

Description of Issue

I can look at the overview of my library:

I can browse through my library and search fast (incl. Qobuz)

Immedately when I want to play a track (via iPAD or Windows 10 PC) the Roon server on the NUC crashes, restart takes some minutes scanning all the tracks:

Crash can be reproduced 100%

After struggling for several years with the Roon core on my QNAP (refer to Roon stopping randomly) I followed the advice of @noris, bought a NUC and moved the core some weeks ago to this NUC; worked from then on rather well: very few crashes only when some audio analysis was running in parallel

but now: Roon server ALWAYS crashes IMMEDIATELY after starting a track!!!

Did’nt change anything (QTS version, Roon version, iOS version, win10 version)

I restarted Roon, restarted the NUC, tried different end points, tried to play different tracks - it crashes always immediately!!! Did repeat that yesterday (5th of January) around 8 p.m. several times.

I stored \\Data\RAATServer\Logs*.txt in Dropbox - File Deleted - Simplify your life


just checked my library, there where appr. 1.100 tracks “deleted”, therefore cleaned my library:

now Roon plays again?!?!?!?!?!?!?

Hi @fschmeis ,

Are you still seeing this issue? It looks like you sent RAATServer logs which aren’t too helpful in this case, but I did enable diagnostics on your ROCK and I am not seeing any of the crashes you mentioned.

Can you please provide the track name / artist if you notice another crash along with the timestamp? Sometimes it is easier to look for artist / track in logs.

Also, I did see some log files end with a backup, does the issue only occur when you’re running a backup? We are looking into an issue with backups causing a crash on large Roon libraries, there is a ticket in progress regarding this.

Hello @noris ,

yesterday I just started to play a track from my iPad and Roon crashed; this happend twice; forgot to note the track, but took the exact time stamps:

  • 11th of January, 2022, 9:18 pm
  • 11th of January, 2022, 9:51 pm

my backups are scheduled to start late in the night, there was no backup running in parallel

where do I find the remaining log files? With QNAp there was a button to zip and store all logfiles - is something similiar for Rock available?


Hey @fschmeis ,

Logs are located under /Data/RoonServer/Logs folder for ROCK:

I see your ROCK is communicating with our diagnostics servers, so I looked over a new log package, this is strange, it looks like your ROCK is running out of file handlers for some reason. I am going to check with the QA team regarding this error.

Can you please let me know how many playlists and tags your Roon database has? Do you make use of lots of playlists or lots of tags on this database?

Hello @noris ,

thx for coming back to my issue.

Yesterday evening, 22nd of January, I

  • started the track “Odd Times” from the artist “Triosence” from Qobuz which played appr. 2 minutes, then the core crashed, this happened at 9:13 pm,
  • waited some time and tried to restart the same track at 09:24 pm - immediate crash of the core,
  • waited again some time and tried to restart the same track at 09:46 pm - immediate crash again
  • gave up and spend the evening without music … :frowning:

no tags in my DB:

In deed, I have “some” playlists and tracks stored in my playlists:

I deleted one playlist (“Marens Lieblings Jazz (u. HR2)”) with 244 tracks, now I can play tracks again :smiley:

Nevertheless someday in the near future I will hit the limit again. How can I “extend” the maximum number of playlists resp. tracks to be stored? What is the actual limit?

1 Like

Thanks for those details @fschmeis ! I am checking with the QA team regarding your case. Do you by any chance recall if you also had this issue on Build 880, or did you install Build 884 on the NUC directly and then encountered this?

Hello @noris , thx for coming back to my issue

yes, PLEASE; just yesterday evening (Friday), 10:43 pm, in the middle of a song, I didn‘t do anything (just hearing music), track was “Morning” from “beck beck” - CRASH in the middle of the song … tried several times again to play a track e.g. 10:59 pm: once I restart the track => immediate crash :frowning:
since I deleted one playlist with appr. 255 tracks I didn‘ add any additional track and didn’t edit any playlist …

Rock says:
I don’t remember which ROON verion was acutal when I installed my new NUC with Rock, the installation was around christmas, and I remember there was one ROON update in the meantime; looking at the point in time when I opened this support ticket: This was 23 days ago; and indeed I seem to remember that these problems occured not from the very beginning on … when was build 884 released?

Hello @noris ,

just saw that a new Roon version is available, thx to ROCK it has been installed automatically:

started Roon remote on my PC - moved to settings to review whether a new remote version is available (didn’t even start a track) - CRASH, timestamp: 1st of February, 10:19 pm

started the remote again, now it showed an available update, installed it, music now playing again :smiley: :smiley: :smiley:… will report … so far playing now for 20 min without a crash :+1: (after several weeks of issues)

</DELETE begin> do you have any infos whether the offending bug has been removed? couldn’t find an appropriate comment in the release notes … </DELETE end>

I was so happy, enjoing my music system again after many weeks of issues, at least for something like 1,5 hours, but when I tried to start a new track “Pirates of the caribbean / The black Pearl” → crash, happened yesterday 1st of Feb at 11:19 pm, tried to restart the track 11:23 pm → immediate crash …


Hello @noris ,

11 days ago you asked the QA people what to do - what did they answer?

It is really boring, at some evenings my HIFI is completely dead due to Roon … some weeks ago I followed your advice and moved the core away from my QNAP TVS 671, purchased a NUC for additional 950 € but still problems … sorry, but I am a tiny bit disappointed …

Hi @fschmeis ,

Thank you for your patience here! We checked with the dev team on this issue and it appears that your ROCK is running out of file handles, but the reason as to why is not entirely clear yet:

Feb  9 15:05:23 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.
Feb  9 15:05:24 (none) user.notice roonserver/run: Error

The team is inquiring what your broker2.db and Database folder sizes are, e.g:

Can you please share screenshots of this info? Thank you.

Hello @noris ,
thank you very much for coming back to my issue.

For sure, my Database:

and my broker_2.db:

below “core” is another folder (without a broker_2.db):

Hope this helps :wink:

1 Like

Thanks for the info @fschmeis , let me get this over to the team for further review!

Hello @noris ,

just installed 903, waited for the database to be updated, then started the first track “Odd Times” (album “Giulia” from “Triosence”) - immediate crash, 15th of February, 7:49 pm :frowning_face:

retried after restart of the core, now running … seems to be more stable than before … will report further on …

What did the QA people say?

Hello @noris ,

yesterday e.g. I couldn’t hear any music, couldn’t start a track from my iPAD, 23rd February, several tries between 10:48 pm and 11:03 pm, track “Tokyo Dance” from “Tingvall Trio”


Hello @support,

after struggling for more than 3 years with Roon running on my QNAP TVS 671 NAS with i5 and 16 GByte RAM (refer to Roon stopping randomly) I spent in December 2021 another appr. 900 € and purchased a NUC10i7 with 32 GByte memory and installed Rock.

But unfortunately after ine week with the NUC things became even worse than with my NAS: Actually at 3 out of 4 evenings I am not able to listen to my music :frowning: :frowning: :frowning: As soon as I start a track - Roon core crashes immediately. This situation lasts already for two months now :disappointed_relieved: :disappointed_relieved: :disappointed_relieved:


Just installed 901 - tried to start a track - immediate crash :sob: :sob: :sob: - Tuesday, 1st of March, 08:00 pm, CET

for some reason: could start to play music via my iPad yesterday evening, Roon was playing for something like 15 minutes, then in the middle of the track “dance” from “Tingvall Trio” the core crashed, I didn’t do anything (besides reading an article), happend 2nd of March, 10:42 pm CET

I just setup a NUC 10I7 32GB just like you However mine runs like clockwork.

My first thought would be to ensure the SSD and memory cards are seated properly , give them a wiggle.

It may be worth downloading a fresh copy of the ROCK OS and start from scratch.

Make a manual backup of your Roon library before starting

Mike’s suggestion is spot-on. This also strikes me as a hardware problem. Possibly the SSD or RAM are bad/somewhat bad. It’s super frustrating trying to troubleshoot ROCK for hardware issues, but, if you happen to have other SSD drives or RAM modules hanging around, you could try swapping them out.

Thx a lot for the fast replies

Indeen, occasional HW failures can be boring … but as the Roon Support already found issues within the log files I don’t expect the HW to be the reason:

I guess a combination of the size of my library (appr. 440.000 tracks) and a limitiation within Roon is causing the issues …

Hi @fschmeis ,

I checked with the team regarding the database size, but it doesn’t appear to be too large, so the cause of the issue is likely stemming from elsewhere. Looking over the logs from the latest Roon build (913), the issue appears to be the same as before, your ROCK Core is running out of file handles:

Line 10767: Mar  4 23:47:31 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.
	Line 10775: Mar  5 00:12:01 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.
	Line 10850: Mar  6 00:14:19 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.

I am checking with the team to see if they have any thoughts on what could be causing this, it also looks like there were a few days when this issue did not occur, I wonder what could be causing it, this is puzzling.

Please remind me, have we tried to eliminate these variables yet?

  1. Using the ROCK on a different network (or at least with no repeater)
  2. Running the ROCK Core with QNAP storage disabled