Roon + Qobuz issues on ISP-provided networking gear

Ah, makes sense. It was probably failing all along. My NUC 7i5 was doing weird things (like never updating the core without losing the database) until I moved it into a fanless case and replaced the RAM, boot SSD, and a frayed SATA cable. Since then it’s been rock solid.


Router/wifi from internet provider is suck. Go get better router please.

If albums are disappearing from your library, this isn’t happening because you have a router from your internet provider or because you’re using WiFi…

1 Like

Georg have you tried plugging an HDMI into it and see what comes up.
I had a M.2 issue on one of my Nucs that I think was overheating and it got destroyed.

I ended up moving to an Akasa fan less case and making sure that it was well seated with paste.
Restored onto a new drive and not had another blip from the NUC.

Your issue may be unrelated, but mine kept needing a reboot in the week or two before the final death throws. Never needed it since.

@Charles_Peterson I’m not this DYI type of guy. If so I probably would build my own Roon core for much less money.

But I bought a Roon Nucleus+ for 2,500 Euro because it’s advertised as plug n play solution.

And I expect support that matches the price point.


I get that you all love Roon, the community and that you all want to protect them because you personally have no issues. BUT this is neither proper support for a high price product nor a solution.

1 Like

@Khang_Nguyen1 My internet provider has proper support though.

1 Like

On one hand I agree with you that if your paying out for an expensive device like a Nucleus to run Roon you’d expect a fair level of support from the dealer who sold it to you, or failing that the manufacturer, in getting it working and I assume this is where most of your frustration lies.

But to use a car analogy, regardless of how much you spent on a new car, if you tried to drive a new sports car on a muddy track road and got stuck, you problay won’t have much comeback, nor will the manufactures be of much help. A car requires a decent road to drive it on.

One suggestion could be for Roon to provide some kind of ‘network checker’ wizard that ran a series of checks to ensure that basic networking standards were in place ie. that DNS worked, that the network had the requisite bandwidth both internally and externally etc.

That wouldn’t solve the underlying networking issues and certainly wouldn’t cover the full gamut of possible networking issues. But it would at least highlight where issues may lie. In the short term Roon’s Networking Best Practices covers what I assume those automated check would cover anyway.

One thing that hasn’t been suggested so far is DNS and some of the issue you outline seem like they could certainly be DNS related. So worth checking you’re not using your ISPs default DNS server which can something be a bit flaky.


Never said you shouldn’t be able to deal with it under warranty from Roon, either fix or replacement. If you know my history here, I’m anything but a Roon apologist. But the Nucleus is just a plain NUC in wolfskin - it can have the same old failures any other modern inexpensive computer can have. It’s why many of us feel the Nucleus is poor value. Thing is, if your Roon Core was made to unobtanium, military, never fails under nuclear attack spec, it would cost 10-100X that.

But anyway, pretty impossible for Roon to diagnose a failing PC, but now you know what it is so problem solved (fingers crossed).

1 Like

Perhaps language is an issue here: are you saying the Nucleus doesn’t power on (i.e. your use of ‘start’) or that it isn’t discoverable on the network? Two very different things.

Ah… just realised that the Nucleus seems to have now died :frowning_face:

I guess a call to the dealer you bought it from, or failing that an RMA back to Roon. If it’s dead (and not your fault) then I assume it will be a straight swap out or simple repair.

Anyway good luck with getting it fixed / replaced.

1 Like

If not discoverable, have you tried resetting the database to your Core (assuming you have it backed up)? That will often take care of these not finding issues (also assuming you can access your Core’s server via browser). If it remains flakey after that then might be a hardware issue so best to return under warranty imo.

EXACTLY after turning it off it did not turn on again.

Here is what bothers me most. You can read everywhere that the Nucleus+ is heavily overpriced for what it is inside. Also, my dealer told me an Inuous is a much better deal and works as Roon core as well. But I thought no one gives better support for Roon Core issues than the manufacturer. BUT there is no support at all.


Also in their Nucleus white-paper they tell you that their support staff connects remotely to your Nucleus to solve problems.

This is why I paid 2,5k. They sold me convenience, but they don’t deliver!

But I already grouped my crunchbase and social media team together to ask for answers from their C and VP level outside this forum.

Yes, I understand the frustration. But if your amp fails you would just get it repaired and not argue about the fact that it advertises: NO SOLDERING SKILLS OR CIRCUIT TRACING REQUIRED. Just get it repaired or replaced. Most computers/ start to do funny things before they fail, and that obviously was the case with yours.

I had a $12k when new Imacon scanner fail on me last year with no motherboard replacements to be found anywhere on the globe (it’s from 2004). Started doing really crazy stuff before it failed. It’s a hunk of useless metal now. Sh*t happens. Digital technology hasn’t quite brought the freedom from inconvenience, cost and maintenance that was promised early on, like something out of the Jetsons. If anything its made life just that much more difficult.

As well, next time probably best to take the advice of your dealer.

@Charles_Peterson I’m with you on the hardware side. My hardware failure post is a completely different thing and a different tonality.

But I disagree 100% when we talk about software and support. I do software for more than two decades and have seen the good, the bad, the ugly.

And when it is the latter, I have zero tolerance.

(Ya ya ya, I already hear ya all yelling, all your issues were supported perfectly or you have zero issues at all. But this isn’t your case here)

I agree with you on all points - my wife is a PM for MS doing releases snd I relate to her some of the Roon stuff (like 1.8 localization gaffe) and she just rolls her eyes and says that’s basic 101 release stuff to get right. So, yeah, they could probably step it up considerably. I will say it was mentioned by support that my having to rest the database all the time might be a hardware issue and I shrugged them off because it worked fine the rest of the time, just when upgrading the OS. I was having network connection issues as well. Well, guess what - since replacing the RAM, SSD, and pinched by mfg SATA cable all has been good. Before I had to steal myself for every update and set aside an hour for reloading the database from a backup, entering passwords and skipped the minor updates. Did this for years. Now it does it in minutes just as it should. Same motherboard and CPU, just Akasa case and better RAM and SSD. Took about two hours to do. All in with NUC, drives (internal 2.5 1TB ssd for music as well) case and memory it was about $800.

So I would imagine that often it is a hardware issue, either with the Core machine, network devices, etc. And of course wonky DNS schemes, poor wifi latency, etc. But if the hardware is up to snuff, it does seem to just run for most users. Sure I have to reboot the remote on my MacBook every few times but it only takes seconds. Minor first world problem. Anyway, I hope you get this resolved in a timely manner.

Hi @Georg_Kuklick ,

It looks like this thread has morphed from a #support topic to a general discussion about Roon and Qobuz + Network stability with many others chiming in, so I have moved it over to the #roon software section where such discussions are encouraged. The #support section is primarily for troubleshooting an issue with a user.

I know this is probably not what you want to hear, but this does indeed look like you are having a networking issue, and this is very likely what is causing the Qobuz issue to occur on your end. I will explain why this looks like a networking issue below.

I have enabled diagnostics mode for your account and what this action does is automatically generate and upload a log set to our servers for review. I see that a log report just came in from your Macbook, so it looks like you are using this as your current Core. Looking over the Macbook logs, this is what logs show:

  1. Connection failure to TIDALs servers and TIDAL sync failure:
11/30 20:43:06 Warn: Error in web request NetworkError (Error: ConnectFailure (Connection refused))
11/30 20:43:06 Trace: [tidal/storage] sync completed unsuccessfully in 19937ms: Result[Status=NetworkError]
  1. Network errors when connecting to our metadata servers to get Qobuz track info:
11/30 20:43:06 Warn: [easyhttp] [3937] Get web exception without response: Error: ConnectFailure (Connection refused) Connection refused
11/30 20:43:06 Warn: [easyhttp] [3938] Get web exception without response: Error: ConnectFailure (Connection refused) Connection refused
  1. Lots of Airplay/MDNS (multicast) requests, once every second, suggesting that Multicast is likely not working properly:
11/30 19:02:27 Trace: [mdns/dacp] [airplay/dacp] got command 'getproperty' value=0
11/30 19:02:27 Trace: [airplay] unknown transport control: getproperty
11/30 19:02:28 Trace: [mdns/dacp] [airplay/dacp] got command 'getproperty' value=0
11/30 19:02:28 Trace: [airplay] unknown transport control: getproperty
11/30 19:02:29 Trace: [mdns/dacp] [airplay/dacp] got command 'getproperty' value=0
11/30 19:02:29 Trace: [airplay] unknown transport control: getproperty
11/30 19:02:30 Trace: [mdns/dacp] [airplay/dacp] got command 'getproperty' value=0
11/30 19:02:30 Trace: [airplay] unknown transport control: getproperty
11/30 19:02:31 Trace: [mdns/dacp] [airplay/dacp] got command 'getproperty' value=0
11/30 19:02:31 Trace: [airplay] unknown transport control: getproperty

Based on these above log traces, I would say that your Macbook is also in an unstable state with regard to adding Qobuz content, so it doesn’t look like just the Nucleus was affected.

The issue here is very likely your router, we have seen ISP-provided gear be underpowered and cause issues, time and time again, and as such we highly suggest staying away from ISP-provided gear. We mention this explicitly in our Networking Best Practices Guide:

Poor quality or underpowered routers can play a major role when it comes to networking difficulties. 802.11n was superseded by 802.11ac five years ago, so at this point, 802.11n routers should be considered obsolete. Furthermore, the performance difference between early 802.11ac routers and current models can be substantial due to differences in CPU/RAM allotments. ISP-provided routers are often underpowered and poorly behaved. Finally, we strongly recommend against using Apple network devices such as the Apple Airport Extreme and Airport Express (note: it’s fine to use the Airport Express as an Airplay device). To ensure the best performance, we recommend against using these devices.

Having the MacBook as the Core on WiFi is also highly discouraged and can cause issues with stability. I suggest looking over this thread for a more in-depth discussion on Roon and network reliability:

I’ve responded to your #support request regarding the Nucleus hardware aspect in your other thread, it’s unfortunate that both issues occurred around the same time, but these should be handled as two separate issues. If the Nucleus was still operational, it is likely we would see similar networking errors.

Hope the above explanation helps clear things up a bit. Do let us know the Nucleus details in your other thread and we can handle that separately. Thank you.

1 Like

Thanks @noris, very useful & helpful, especially for the newbies w/o comprehensive computer/networking know-how.

Btw, Nucleus works fine for me since day 1, not a single issue, and still going strong. If anything happens (finger crossed) it is more likely some hardware issue(s) (SSD corruptions, RAM chips popped out, etc.).

1 Like

I have an iMac (2019) as my Core (on WiFi). I also use an ISP-provided router (Fritz!Box 7490). And I’m really glad I have absolutely no stability issues with Roon + Qobuz. However, if I were experiencing the kind of problems described on this thread and Roon support advised me to get another router, I’d be more than frustrated. Music software that requires industrial grade networking gear? I can only speak for myself, but I probably wouldn’t swap my router just because of Roon, definitely not if Roon were the only software having problems with my Fritz!Box…

1 Like

Hey @noris To your points:

This probably happened because your support was completely absence for some days! There was enough time for all others to water down the thread. They all felt like telling me that they have no issues. It’s still a support issue.

I know this is probably not what you want to hear. The logs you made are not from the former “too-cheap-for-roon” internet-provider network equipment. I bought some f*cking expensive top-notch netgear router.

Also first and foremost you mention: NO COMPUTER OR NETWORKING SKILLS REQUIRED

I used the MacBook as Roon Core because my Roon Nucleus+ stopped working entirely!

No it doesn’t it’s still no support and no solution!

You sent me some network errors, like: “Here see, there are some network errors. They explain all your problems.” No, they don’t. Not even close. If so, match the network errors to the existing issues and give me advise how to fix them. And this advice needs to be something like an easy to follow step by step instruction for computer dummies. Because: NO COMPUTER OR NETWORKING SKILLS REQUIRED

1 Like

Hi @Georg_Kuklick ,

I’ve followed up via private message so that we can work on these issues one-on-one in a support context.