Roon Won’t Read External HD After 1.8 Update

Roon Core Machine

MacBook Pro Core OS 12.3.1, Seagate External HD

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Since updating to 1.8 Roon won’t read my music on external HD. Nothing else changed.

I have discovered that if I play a file on the HD through Apple Music it will appear in Roon. But I have several thousand tracks on HD and would take me hours to do this.

Have you tried to force a rescan of the external hard drive in Roon?

Yes and have ejected and restarted HD as well as rebooted computer

There was another thread on here in the past week that MacOS may spin down an external HDD which may cause a hiccup in Roon. Not sure it is related as you mentioned that you tried a forced rescan.

Have you tried copying a test file or album into a new directory on the HD and having Roon scan that? There may be something in the original directory that is causing this problem. If a test file or album works, maybe moving all of your music into a new directory on the HD will correct whatever Roon is stumbling over.

Interesting. When I tried to do this in Roon>Settings>Create New Folder I tried to click on the HD but got a mesaage on Roon “Error loading folder. Unauthorized.”

I recommend creating the test folder from the Mac, then select this path within Roon as another folder option. Is the drive formatted as a MacOS APFS drive, HFS+, ExFAT, or NTFS? I’ve seen some recent messages having to do with MacOS and NTFS drive issues.

It is APFS. Unless I don’t understand you correctly I think that is what I did. I used the Mac to set up new test folder on my HD. When I went to create a new folder I could not do it based on error message cited earlier. I can manually copy files to my Music Folder in Roon but time consuming.

Screen Shot

Don’t know if you can access this but screen shot of what ppears when I tried setting up my teat folder

Thanks Ricky, I was able to see your screenshot. Does the external Seagate drive have a password or other secuity associated with it? I have APFS drives attached to my MacBook Pro and typically don’t see notifications such as this.

What I was suggesting, if we can get this to work, is that if the test file or album can be read by Roon in the new folder, it’s very easy to copy all the files from the directory that isn’t being read by Roon into the one that can be read by Roon.


I saw this in another topic I’m monitoring and it may help as it seems similar to what you are experiencing:

Robert thanks for help but no luck so far. Can’t find anywhere to grant full disk access in Roon, the Seagate or Mac Settings. In addition the ‘workaround’ I thought I had discovered…selecting all tracks on a file and then opening them in Roon…did not work. All the tracks/files I though I had added disappeared from Roon once I rebooted. The only way right now I can add files from the HD to Roon is to startpalying an individual track from iTuens. Those are styaing visible Roon but would take me a significant amount of time to add. Literally nothing changed except the Roon update. Frustrated because at this time it seems like I will either have to be satisfied with Roon as a fancy Tidal player with metadata or but a seperate HD, back up my files on that and see if I can create a new path. Thanks.

I’m tagging @support. One last question. When you select “Get Info” on the external Seagate drive form your Mac and scroll to the bottom under “Sharing”, what is displayed?

On one of my external SSDs, I have

my username (“Me”), with Read& Write privileges,
then “staff” with Read & Write privileges,
then “everyone” with only Read privileges.

I added a test directory on this drive and asked Roon to monitor it, which it did. I’m wondering if an access privilege is misconfigured for you.

That is what shows up under permissions on my HD. Thanks again

Excep that “wheel” is shown with Read & Write

Take a look at this post – it goes through how to grant full disk access for Roon. My guess, as you’ve already confirmed that this isn’t a permissions problem with the hard drive, is that your Mac ‘forgot’ that it had access to this folder when you updated Roon.

EDIT: If System Preferences shows that Roon does have ‘Full Disk Access’, click on Roon in the list, then the minus button just below the list. This will remove Roon from the list. Once you’ve done this, click the plus button and add Roon again.

1 Like

Thanks @DaveN, haven’t needed to do that on my Core. Hopefully it helps.

1 Like

Well that fixed the original problem…the Roon box had been unchecked in Disk Access…but now have several others. When I booted up Roon got the message that the latest update required a database update…normal. But Roon is now showing files that are not audio and I have no idea what they are. And when I try to login to Tidal from services the screen is frozen for login to Roon.

Screenshot of Home page showing unknown files

Screenshot of where I am frozen trying to sign in to Tidal

And have no idea whether this is at all related but the little semi-circle at the top right…kind of a version of the spinning colored wheel of death…keeps spinning and has been sonce I booted up 20 minutes ago