RoonBridge Zone drops with 1.3 build 208

I’ve rebooted everything. After this last update, RoonBridge does not work. The zone is dropped when anything is played. @support

208 good here. PC server, Linux bridge.

I’m running RoonBridge on a BeagleBone Black. Everything worked fine with RoonBridge (build 73) from day one of RoonBridge until this latest update. Now completely broken. The Zone drops entirely when a file is played. The zone comes back after about 30 seconds, but nothing can play.

Bridge is runnng build 73 on a Intel DN2800MT.

I am getting this error in the logs:

03/01 19:23:53 Warn: Error in web request NetworkError (The remote server returned an error: (502) Bad Gateway.) @support

Can you give us the full details of your setup @fritzg? I assume everything has been rebooted?

Here you go @mike

Core: i5 NUC 8 GB RAM, 256 GB SSD, 2 TB HD, Ubuntu Server 15.10

RoonBridge: BeagleBone Black, Debian Wheezy Image 2015-03-01

Remote: MacBook Air, 4 GB RAM, 256 GB SSD, OS X 10.12.3

Everything is up-to-date and has been rebooted. Roon works to Airplay devices and the BeagleBone works as a UPnP device. The BeagleBone RoonBridge has only failed with this latest upgrade.

Any word on this? Build 208 for the Core and Remote and Build 73 have broken my installation of Roon.

Bump. Should I assume Roon has all it needs to solve this issue? I’ll be taken no down this system and eliminating the streamer tonight if no word. @support @brian

Hey @fritzg – sorry for the trouble here. Clearly something has gone wrong in your setup, since we’re not hearing about any widespread issues, but I’m sure we can figure out what’s going on.

I believe you said in a different thread that you’re running a fresh install of Roon Bridge. Can you walk me through exactly what you did? I just want to ensure you’re running a fresh install, before we look deeper into this.

I am having the same issue i.e. Zone being dropped for USB devices (HDVD800 and Marantz NA-11S1). Airplay works fine.

1 Like

@mike I logged into the BeagleBone and reinstalled RoonBridge using these commands, answering yes if I wanted to delete and reinstall. And let me be clear, it worked just fine until the upgrade to build 73 and builds 207/208. The device also works fine as a UPnP player.

Roon Bridge armv7hf
$ curl -O
$ chmod +x
$ sudo ./

@Arif_Iqball and @fritzg ---- Thank you both for your feedback.

@fritzg I will be contacting you momentarily via PM with further troubleshooting instructions. Please stand by.

@Arif_Iqball — In order for us to understand the behavior you are experiencing, can you please provide us with the details of your setup as seen here.

Furthermore, may I ask you to please clarify your statement for me so I understand what device is acting as your Roon bridge . Thanks!


Thank you for the quick reply.

My core is on a Synology 1815+. I have had zero issues for the past many months till the new build was installed.
I am posting my settings

Both devices attached to the core are not working. They are attached using USB. Airplay is fine. Both these devices were working fine till the latest update.

Please advise if additional info is needed. Thank you again!

Thanks @Eric. Look forward to the instructions.

Sent the logs and such via PM to @Eric is @mike also monitoring that PM thread?

Just copy/pasting my message from the other thread on this issue.


Yep, same here. Build 73 broke my beaglebone bridge as well. Just came to the forum to see if anyone else was having the same issue.

As soon as I try to play something on it, it just drops off the network and roon asks me to select another zone.

It enables itself back online after some seconds, but breaks immediately as soon as I try to play anything on it. :confused:

If I replace my beaglebone black with a raspberry pi3 that I use for other stuff everything works great again. So it seems to be something on the beagle that doesn’t like build 73 or vice-versa.

Also running Debian Linux 3.8.13-bone70 armv7l
(Debian 4.6.3-14)

The same Debian Image 2015-03-01 fritzg seems to be running.

I can put the rest of the system specs as well if you wish, but the beaglebone black seems to be the common item.


Hi @fritzg @Skywatcher @Arif_Iqball – we took a look at this and we think we understand the issue.

The issue here is that some Linux devices appear to be using a version of ALSA that is older than we recommend.

Some situations in which this older version of ALSA worked in the past may be less tolerant with our most recent release, due to some unrelated stability fixes. We believe we understand why this is happening, and we’ve already made a change that we hope will help people running older versions of ALSA. This will need to be tested before it’s released.

For now, the only real work around is to use a more current version of ALSA. We’re not sure if newer versions of Synology firmware includes a newer version of ALSA, but for issues related to Beaglebone, you may be able to resolve this by switching to something like DietPi which may include a more current and fully tested version of ALSA.

Thanks and sorry for the inconvenience guys – we really hate having people stuck over the weekends, and we’re going to rush the next release out as soon as possible.

Thanks all!

In the mean time, you could try flashing a more recent image and install Roon Bridge on that – the latest appears to Debian 8.6 (Nov '16):

Thanks, @mike. This has been such a good turnkey solution I was surprised when it failed.