Slow TIDAL performance & errors

Tidal is very slow for me as well, sometimes so slow Roon reports failure. Usually it takes maybe 10 seconds to start playing a tune (but once started it seems to pre-cache upcoming tunes).

My internet speed feels fine and normal for other things, so this is probably a Roon or Tidal issue. Removing the cache did not help.

Btw, my cache took up 1 Gb and had 50 thousand files, so probably a good idea to remove it.

1 Like

I can add that starting files I have locally (flac and DSD) is fast

Thanks for reaching out, @Magnus!

I’ve moved your post to it’s own thread so we can take a closer look. So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Have you tried giving Google DNS a try? We’ve seen similar reports improved by using it.

Can you also verify that TIDAL is playing fine outside of Roon on the same Core machine?


A post was split to a new topic: TIDAL experiencing slow performance

Tidal Desktop app works fine, takes 1-2 seconds to start a new tune. So its likely not a normal computer/network related issue.

My setup:
Running Roon on Windows 10 64 bit
Intel i7 CPU with 16 GB of memory and very fast SSD disks.
Latest version of Roon (1.5 build 339)
Using Allo USBridge connected to a Pro-Ject Pre Box S2 Digital

I tried to bypass the Allo USBridge, using DAC connected directly to the computer, but the issue remained so its not an Allo USBridge problem.

Thanks for the info, @Magnus!

Can you verify what kind of networking hardware is in use and how the Core machine is connected?

Have you tried rebooting the Core machine since experiencing this behavior?

Additionally, we have also seen Google DNS help with similar reports. Can you try using Google DNS and let us know if you notice a change?


Tried Google DNS but that didn’t help (as expected, this does not seem to be a generic network problem).

Some additional info: the first song I play with Tidal Desktop App is also slow, but after that its fast (only tried like 10 tunes though). In Roon, some tidal tunes starts fast but some starts slow. Maybe some Tidal handshaking that takes time, and is only done once in Tidal Desktop app?

Thanks for giving that a try, @Magnus!

Can you confirm whether or not this is new behavior or if this has always occurred for this Core machine?

Can you please try the following:

  • Logout of TIDAL in Roon
  • Reboot the Core machine
  • Log back in to TIDAL in Roon


No change. Btw, it also happens that you get a drop-out after about 5 seconds. I tested both MQA and non-MQA and no difference in behavior as far as I could tell.

Hey @Magnus,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Ok, right now, took 12 seconds to start “Rock you gently” by Jennifer Warnes from Tidal. About 19:20 CET

Thanks, @Magnus!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


2 posts were split to a new topic: TIDAL performing slowly

Here is another, where the tune started after 10 seconds, then a few seconds later I got an error in Roon and it skipped to next tune:

Eric Clapton - Blue Eyes Blue - 10:29 CET 21 September

1 Like

Just an update: I haven’t seen this problem in a couple of days, so seems something has changed. Or maybe its because it’s weekend and less internet load.