TIDAL acting slowly - takes long time to buffer

I am having the same issue. It’s not my network. Roon takes 30 seconds to load a song. Can’t stop buffering if I change an album. Very bad today.

Hey @late_nighter23, I’ve moved your post into your own thread so that we can address your concern.

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Additionally, as a first step, could you please try changing to DNS? We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?

Thanks so much!

The issue is clearly with Roon itself especially bad since the 1.8 update. Seems worse
late at night which is when i am doing most listening (hence the name). i just changed to the google dns as you suggested, but like i said, i have had roon a few years and this has just started recently.
I am hardwired to the internet connection via mac mini m1. i use a sotm sms 200 into a mcintosh
mha 150. Pretty simplistic set up and like i said it worked great pre the latest
roon update.

A post was merged into an existing topic: TIDAL only plays when lowering streaming quality

well as you can see, i am a customer for 4-5 years. they put all the onus of the issue on me, and offer no direct support such as an email, a virtual consultation or phone support. if i was not so invested i would look elsewhere to be honest with you, having said that i am about due to fork over another year membership because i am too deep entrenched in terms of my listening experience. the tech support
could be A LOT Better.

What is the backbone of your network? What is providing your networking? Modem, router etc? How is the SOTM configured? Fixed IP? DHCP? Whilst it may have been working, there may be other things at hand - that may not be Roon - causing issues. IP Conflicts etc. The more info you can provide, the more someone may be able to assist with less guesswork.

I am hardwired from the modem to my computer. you are not asking me questions that the average consumer without technical knowledge would even know what you are talking about. i have no idea if i have a fixed ip. what is the question regarding dhcp? i have no idea about that either. it worked fine for many years on different machines. like others have noted tidal runs really slow after
the last update. there are times when i can’t listen and have to keep getting up to restart the program in order to listen. that’s about all i can tell you from my end. to me not being very versed in this stuff it
would seem the issue came from the update. this sort of ties in to what i was saying about the
technical support. i mean if i call apple, they walk me thru the tests. exactly what to do etc. this is not what’s going on here. you just assume i know what you are saying and i have no idea what your last message said beyond a certain point. maybe this is something else for roon to work on without guesswork on the behalf of the customer. not trying to be rude but it’s a little irritating to be frank. It’s also not as issue that happens all the time. Some days are better than others.

1 Like

No problems. Appreciate the rant and its always frustrating when things don’t work. Good luck. Hope you get it sorted.

A post was merged into an existing topic: TIDAL only plays when lowering streaming quality

You are not alone in your frustrations. I’ve been through 3 weeks of attempting to diagnose this problem in my own previously stable network. The current support system seems to be creaking under the weight of problems caused by 1.8. I imagine the staff are dreading starting a shift armed with next to nothing and backed by a programming department that has recently dumped on them from a great height.

Hopefully the number of reports of issues with Tidal will begin to make Roon realise they have a problem that’s bigger than users DNS settings. FWIW it happens with Qobuz too.

It can sap one’s enjoyment of music pretty quickly trying to get meaningful support from Roon. I don;t blame the individuals they’ve employed to dot it, they just need more of them and better development and testing. Growing pains that will ultimately decide the success or failure of the platform.

Sorry Sean i assumed you worked for Roon, my bad for the rant!

if the owners spent less time expanding and more time providing actual customer service and support, it would go a long way. i still have not received meaningful help for my issues.

@late_nighter23, I appreciate you trying another DNS and for letting us know it didn’t help. We would absolutely love for this issue you’re experiencing to be solved, but in order to get there, we’ll need some more information so that we can pinpoint where the error is occurring. To determine this, we’re hoping that you can answer a few questions/try a few steps.

  • How often does this happen, that TIDAL takes 30 seconds to load a song?

  • If you go to speedtest.net, what is your download speed?

  • Does the situation improve if you lower the streaming quality? You can change this by going to Roon Settings → Services → TIDAL (Edit) → Streaming Quality (choose a lower quality)

  • What happens if you disable IPv6? Do you still have issues with constant buffering?


i don’t know what ipv6 is or where to locate it.

it happens mostly late at night nyc time around 1-3 am,

i was unaware i could lower stream quality so i have yet to try that.

i did a speed test when it was occurring and the network speed was not the issue. my download speed was 220 mbps

I managed to disable IPV6 on my router in an effort to solve my Tidal woes. No change. I know this probably doesn’t help you but I had to access my routers settings and read the manual before I could find the right button to click.

I’m not convinced the problem is with the network but it’s a convenient complication to distract from the possibility that it could be poor programming.

At the same time 30 secs to load from Tidal is extreme. My playback devices are getting timed out after 5 seconds.

I am not using a router so is that something I need to find it? I have no idea what it is. They didn’t explain where to find it. That’s what I am talking about in regards to better tech support.

@late_nighter23 if you’re not sure how to disable IPv6, I found a set of directions online that might be helpful to you: How to disable IPv6 on macOS; you should be able to disable this even if you’re only using a modem. A router is not required to disable this.

I hope that helps!

By the way, have you had a chance to try lowering the streaming quality? Did that help at all?

@ashley the link you provided is not for the current mac os and currently there is no option to turn off
ipv6. i am attaching a screenshot of the available options.
i have not attempted to lower stream quality yet.

conversely i will not go into terminal and start making changes. so that’s not going
to be an option i am willing to try without being on a call with tech support while doing so.
too many things can go wrong and i have zero background dealing with this level
of tech. a situation like this would be a great time for roon to offer more personal tech support. i am
sure you are busy and a nice person but this is not helping me just to be transparent.

This lowering the Tidal quality reminded me. When I tried that I just get a couple of seconds of digital screeching instead of Tidal tracks.

By my understanding IPv6 is a longer form of IPv4 which will allow us all to have the huge number of IP addresses we are going to need in the future. In which case this is very much the business of a router and telling your router not to use IPv6 will have the effect of stopping your computer from using it.