Too Many Failures - Stopping Playback

Roon Core Machine

2021 M1 MacBook Pro with 16GB of Ram running Ventura 13.0

Verizon Fios plus eero pro 6e gateway and mesh network accessed via Wifi ( moving to ethernet shortly )

Connected Audio Devices

I am trying to play through my Macbook connected via thunderbolt to Apple Studio Display - will be using dedicated system once this is up and running

Number of Tracks in Library

3,500 albums

Description of Issue

Hi, I am using Roon but cannot play from Tidal. Every album I try skips quickly through all titles before telling me “Too Many Failures - Stopping Playback” while local files seem to play OK.

Can someone help me get this sorted? I have gigabit internet that has no dropouts, and playing these tracks inside the Tidal app ( with no Roon anywhere in the system ) is immediate and error-free.

Can someone determine what I’m missing?

Have you tried turning off the firewall (System Settings → Network → Firewall)?

Thanks for the reply. The firewall is off.

Hmmm, not sure what else it could be, but this might be worth a try:

Your internet speeds are important, but not more important than your intra-net speed. If you are doing all Roon connections via WiFi, then that is your problem.

The Core at the very least should be connected via Ethernet.

1 Like

It could be, but it’s certainly not a definite. I would have thought that a decent mesh network would be able to handle Tidal streaming. At worst, I’d expect some dropouts, but not a total failure to play anything.

1 Like

I had previously tried logging out and logging back in and that didn’t work. I have just now tried changing my password, and that didn’t work either, unfortunately.

with the new password, Tidal still plays flawlessly in both the browser version and desktop app.

@xxx - sorry i meant to hit reply here:

The Core is a Macbook - which I’ve been using for six months with Roon without this issue - and it’s not going to be connected to ethernet very often. In fact, I don’t think it ever has been. So, to be clear, the “stopping playback” issue is happening with the Core itself.

The mesh network handles 4K video streaming without issue and, again, Tidal plays perfectly everywhere else on this computer, as do all other websites and videos.

1 Like

Just want to say thanks to all who have replied here so far. Is there any other information I could provide that would be useful?

If you do a forum search on the message you are getting, you will see that using a Goggle DNS has sometimes been suggested by @support.

Good luck.


Alternatively, try (Cloudflare) rather than (Google). Either will probably perform better than an ISP supplied DNS.

I have AT&T Fiber and when I switched my DNS from AT&T to Google many of my home network problems stopped immediately, so I like that response as a first step.

Can you provide some additional information on your WiFi network? Roon requires a bit more demand on your home network due to its synchronization capabilities across endpoints (which performs very well). The behavior you are experiencing with Tidal seems to be related to your home network. Even if you can stream 4K TV, the manner in which TVs and TV apps, and even Tidal’s native app, stream is different compared to how Roon does this.

Does your FiOS router still have its WiFi active? Are your eero 6E devices using the same SSID as the FiOS if the FiOS router’s WiFi is active? Alternately, is your eero network a separate network from the FiOS router network?

One other potential issue. The 2.4 GHz WiFi network is very crowded and has less capacity than 5 GHz WiFi networks. It does not appear eero configurations allow you to separate these networks into different SSIDs, so it may make sense to try turning off 2.4 GHz WiFi if possible on your MBPro and other devices to force them to use the higher capacity 5 GHz WiFi network.


Thanks very much for this. Super helpful.

Of course, before I did any of this, my Roon started playing things correctly. No changes to the system, no changes to the location, and it just started working as expected. I guess I should mark this solved, but it’d be nice to be able to have an explanation as to what was going on.

Thanks to all for your help.

I’ll post it as Solved so the Roon staff can focus on other customer issues, but they will probably look at this.

One area I have been involved with for many years is WiFi. As the eero devices do not allow you select which band to use, it may have sensed some interference resulting in your problems, changed to bands that may not have worked well in your home for Roon, and then sensed that the interference stopped and changed your network again to a more stable configuration.

Unfortunately, the problem has returned.

I’d appreciate it if you could un-solve this so that Roon Support might be able to take a look and we can get this solved properly.


Does your FiOS router still have its WiFi active? YES

Are your eero 6E devices using the same SSID as the FiOS if the FiOS router’s WiFi is active? NO

Alternately, is your eero network a separate network from the FiOS router network?
The eero network is separate from Fios.

Could you help me understand why every other app would work perfectly well except for Roon - and how I can diagnose? I am not even using Roon endpoints at this point - literally trying to get the Core to play Tidal files on the MacBook speakers that the Tidal app itself has no problems playing on my phone, or on either the browser or desktop apps on the same laptop.

What is the benefit to using Roon if can’t stream files that Tidal can?

HI @Roeyjose,

Diagnostics show me that Roon isn’t able to communicate with Tidal and can’t even get the time from our servers for authentication. In your current diagnostic log alone there are almost 2,000 instances of networking errors or timing out. Is your FIOS in bridge mode? If not, we have our culprit.

Ideally, your core would not be wireless. In fact, Roon advises against this. Please see the article below:

If you have no choice other than to use Wifi, please try and connect the Mac directly to your router and see if the issue still occurs. If it does, let me know and we can dig deeper but I feel pretty confident that networking (one way or another) is our culprit.

As a side note, I want to address your comments regarding other apps and services. Roon requires a lot of your intranet and depending on the size of your library, your machine. Most users with decently large libraries have a dedicated Roon core for this reason. We have a proprietary technology we have built from the ground up called RAAT. The article explains a lot of things but at a glance, you should be able to see how Roon’s technology isn’t the same as opening up an Amazon Music and hitting play. In addition to the features of RAAT, you are also building a database with Roon that customizes your listening experience as you browse and play music.

I hope this helps.



Thanks for the links. Much appreciated. I will read up and see if a Nucleus ( instead of the Mac Mini I was planning to use eventually ) makes sense. Seems like a big ask considering I’m not having any streaming issues anywhere else, but I agree that a larger library might justify the expense.

Thank you!

From what I can make of @Wes’s comment, the problem lies with your network, not with the device that’s running your core, so getting a Nucleus wouldn’t make any difference.


Before you buy a probably unneeded Nucleus to solve the current problem, attach your Core via Ethernet to see if that makes a difference.