Blank device name

I have the same problem with both iPhone X and iPhone 7 with the latest available iOS and Roon. It is very annoying. Roon crashes with this issue every time try to use the iPhone as an endpoint. Will update this message with more repro details…

[Edit] Sorry, it doesn’t crash every time, but a few times a day. Usually, when the iPhone has been idle for a while since the most recent listening session.

Hi @hacker19
Yes the problem continues for me also. In my case it is fairly intermittent maybe every 3-4 times I use my iPhone or iPad and mu iPhone is a 7s so it clearly is a problem on multiple Apple devices and yet it would appear @nuwriy that Roon have not been able to reproduce this?

Core Machine (Operating system/System info/Roon build number)

2014 Mac mini

2.6GHz intel core i5

Memory 8GB

Yosemite 10.10.5


Roon 1.7 Build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear R6400, all devices on WiFi (our new house doesn’t have ethernet wiring :-()

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iPhone 7 (iOS 13.3.1) / iPhone X (iOS 13.7) as endpoint

Description Of Issue

From time to time, the iOS endpoint disappears (not visible from any Control, not just the iOS device in question). Go to Settings >
Audio. The IOS device shows with a blank name and stuck on “Enabling…”. Enter a name, hit Done, the app crashes. Start Roon app. Sometimes the problem fixes itself, other times, I have to repeat the above process. It is some combination of the iOS app and Core. I don’t have this problem with the “dynamic” endpoint on my MacBook Pro. What I mean by “dynamic” is the device can go to sleep and wake up, unlike the “static” endpoint on my Mac mini, which is always on.

Thanks for that @hacker19
It is the same for me
I have two Auralic end points both fine, both can sleep
An iMac and MacBook Pro both sleep as well
And two SqueezeBox radios
All of these are fine it is only iOS devices that exhibit this problem for me

This is the “Enabling…” screenshot. It is stuck on this.

I was watching the RoonServer log when this happens (the screenshot is from an earlier time than the log below :)). Looks like RoonServer wasn’t able to connect to the RAATServer in the iPhone:

09/08 18:43:44 Info: [raatserver] [’s iPhone X] connecting (attempt 2)
09/08 18:43:44 Warn: [raat_ll/client] [’s iPhone X] failed to connect Connection refused
09/08 18:43:44 Trace: [raatserver] [’s iPhone X] client connection failed. Retrying in 750ms
09/08 18:43:44 Info: [stats] 5473mb Virtual, 2035mb Physical, 1342mb Managed, 100 Threads, FDs
09/08 18:43:45 Info: [raatserver] [’s iPhone X] connecting (attempt 3)
09/08 18:43:45 Warn: [raat_ll/client] [’s iPhone X] failed to connect Connection refused
09/08 18:43:45 Trace: [raatserver] [’s iPhone X] client connection failed. Retrying in 1125ms
09/08 18:43:46 Info: [raatserver] [’s iPhone X] connecting (attempt 4)
09/08 18:43:46 Warn: [raat_ll/client] [’s iPhone X] failed to connect Connection refused
09/08 18:43:46 Trace: [raatserver] [’s iPhone X] client connection failed. Retrying in 1687ms

Either there was a bug that caused the RAATserver to not come up, or it crashed, or RoonServer is using the wrong IP:port for the RAATServer. Or could it be a transient router issue?

@nuwriy send me a PM and I can send you a link on my google drive to the log file.

Asking me to name an existing zone appears to be a bug in itself. BTW, when I invoke device setup, make a change and save it, “Enabling…” briefly appears with a blank name, but it goes away and the correct zone name displays. Looks like it is in the same/similar codepath.

Hi @nuwriy

As @hacker19 says the problem continues (thanks @Hacker for the detailed bug tracking)

I have done some searching on the portal and in id order (2 users)

This was split into a new post for a different user: (1 user)

This suggested a fix of uninstalling and reinstalling the app but I have tried that and it did not resolve the issue.

There is also: (7 users)

And: (4 users)

And: (1 user)
This suggested the same fix as 43694.

And: (6 additional users)

There may of course be others who have posted but I haven’t found the right search terms to find. So this seems a widespread issue.

There are only two suggested solutions that I spotted
Roon suggest uninstalling and reinstalling Roon Remote - doesn’t work in my case. @hacker19 you may want to give it a try in case it works for you.
The other was suggested by @dannybgoode who reserved the IP address for his device which he says worked for him so I will give this a go.

OK I tried the fixed/reserved IP address fix but again doesn’t work for me

Neither of those worked for me either.

Hello @hacker19, and thanks for reporting this. I’d like to get a report over to our QA team for further analysis. Could you please reproduce the issue one more time, reply here with a timestamp of when you do, and use the directions found here and send us over a set of logs using a shared Dropbox link.

09/14/2019 09:52:00 PDT

The log files have personal information (email address for example), so I’ll send the zip file in a personal message.

Hello @hacker19, and thanks for the link! I’ve sent these logs and the details of this thread to our QA team for further investigation. I’ll return here once I have their feedback!

Hi @nuwriy, @hacker19

In my similar post ( ) I think I found a solution to my issue and have posted it there.

In brief I changed my DNS to use Cloudflare and then also diagnosed a faulty network cable to the core machine.

Since those changes I have not seen the issue recur.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.