Chromecast audio and Android remotes no longer visible to Roon

@Robert_Lowe

… connected the RT88XU, configured it to use EXACTLY the same 2.4Ghz and 5Ghz SSIDs and passwords

I’ve experienced the same thing with Chromecasts, for me this helped:

Quit Roon.

  1. Remove all Chromecast devices from Google Home.

  2. Tap “forget network settings” in settings for all Android devices, then manually re-enter all network settings. Next clear cache for Roon remote app.

  3. Disconnect all Chromecast devices, PC, router from the power supply and restart, restart Android devices.

Re-add Chromecasts in Google Home, open Roon.

Good luck!

Not sure to be honest, I have struggled in the past with an Android phone. I currently use an ASUS RT AC86U on stock firmware IGMP snooping is enabled under wifi and Multicast Routing is enabled under LAN IPTV . Currently both Chromecasts and the Android phone are identified and enabled by Roon. I do recall on one occassion having to insert the IP address for core ( under help) when the android remote couldn’t connect.

ASUS Routers

We recommend enabling “Enable Multicast Routing” option in settings.

Chromecast devices do seem to be unpredictable. I lost all of my actual Google devices at one point whilst my inbuilt Chromecasts still showed up.

Another data point would be to use something like Fing to verify that the WiFi devices are on the same network subnet as the roon core.

Hi @Rugby I can see all the devices on the subnet through the router and my Android devices all use Network Monitor; I’m in no doubt as to the common subnet.

Hi @Axel_Lesch Did this. Ripped out my entire Google Home setup including every last device. I reinitialized the LG soundbars with built-in Chromecast and rejoined them to the LAN. I reinitialized two Chromecast devices and also rejoined them to the LAN. All the devices have different names. I removed the wifi configuration on all the Android devices and then rejoined them. I removed Roon entirely from all of those devices in the interim and then reinstalled on just one device. None of this has had any impact. Roon continues to see 0 Chromecast devices, and the Android tablet that I just reinstalled Roon upon can not communicate with the Roon Core on my PC. Router reboots and PC restarts haven’t helped. So I continue to have a Roon installation that can’t interact with anything on my network. Other audio applications (Media Monkey, Tidal) can cast (from the same devices that can’t talk to Roon) to the same devices that Roon can’t even see, so this is looking to me more like a Roon-specific problem.

Hi @Steve_Howlin, I have enabled both settings on my router to no avail.

Sorry it didn’t work, the other WiFi setting I have disabled is under ‘wifi professional’ is ‘Airtime Fairness’ . This was set as a recommendation from snb forums as a 'basic setting for reliability and a google shows possible advantage with it disabled for chromecast devices. However I agree if they work on Tidal why aren’t they working on Roon

Post #4 different router but I believe still applies

That’s too bad, @Robert_Lowe sorry.

Well, another idea.
You may temporarily disable AiProtection firewall and/or check your router’s security settings (manual Page 30).

@Axel_Lesch I had already turned off the AI Protection. That hasn’t had any impact.

O well :wink:
@Robert_Lowe, one last idea …
The Asus router is connected to a modem, right?
How is that configured?
Is the modem in bridge mode with NAT and DHCP disabled?
If not, double NAT could be the culprit. Anything that automatically opens ports like UPNP will fail, because the “outside” NAT can’t be accessed.
@support should be able to answer exactly how this works with Roon.

One last question - the Core PC is connected to the Asus router and not to the modem and Roon is configured as an exception in the PC’s firewall?

… if none of this applies, I have no clue anymore (except maybe to factory reset the Asus) :slight_smile:

Hi @Axel_Lesch The router is connected to a Surfboard cable modem that has no user configurable options. It is in exactly the same state as it has always been. The Core PC is connected to the Asus router. As mentioned, both roon.exe and raat.server are allowed in Windows firewall for both “public” and “private” networks, which is the configuration that I’ve always had. And with due respect, I’m hard-pressed to see why a change of router would require enormous painstaking efforts at tweaking every possible setting to get a solution that is sold as broadly functional to work. If Roon can only work on specific devices with specific configurations, then where’s the list of the devices and configurations? I’m not averse to a certain amount of device management but if you ship software that only works on X routers configured in X manner, then publish that (and this does not qualify) or get your product off the market. Or respond to user requests for help. No one from Roon has appeared on this post.

Hi @Robert_Lowe,
if you still want to try something last - maybe the old router was set up as an acesspoint?
It’s simple and just as easy to undo as “Router mode”.
If it should work against all expectations this time, haha, don’t forget to change the DNS server to 8.8.8.8 and / or 1.1.1.1

Hi @Axel_Lesch The previous router was not running in AP mode, and neither is the current one. And again, all the router questions seem, in my view, to be less relevant in view of the fact that the only software having a problem with any function is Roon. It’s difficult to imagine that no other application or device would have a problem if my router were misconfigured in some material way. I have 32 devices on this router and other than the Roon core on a fairly muscular PC with a wired connection to the router, there aren’t any issues.

Update. Okay, so the problem turned out to be that Windows apparently set my network profile as “public” in conjunction with the change in router. I never even looked at the d*$#&ed adapter settings since nothing else was wrong. Evidently this matters for Chromecast devices (and I expect for Android ones as well if they want to talk to a service on my PC). So that’s that. I have not met my own troubleshooting standards on this issue. :frowning:

Windows does love to screw you over and resetting your networking is a golden opportunity.

My JBL Link 300 and JBL Link 10 Chromecast speakers recently disappeared from Roon Settings Audio. They still appear in Google Home and will happily play from YouTube music when requested with a “OK Google play…”

I tried adding a second JBL Link 300 to my Google Home and it added fine, but Roon does not see it.

My Sonos One is on the same wifi network and still appears listed in Roon Settings Audio, which leads me to believe the problem is not with my network but a Roon Chromecast problem.

Hi @Bandersnatch,
usually that’s a security/firewall settings issue, you may read:

Thanks Axel - will check the links out them. I did switch all my firewalls off and no joy.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.