New backup problem?

Because I was inadvertently backing up a long corrupted library, I decided to delete all my backups and start fresh.

Today, I ran into this problem on a backup destination on a Mini that was working.


This -

or this -

both result in this -

Selecting the Clean/Restore option -

Also results in this -

The other backup locations listed here are OK -

There’s plenty of space on that drive -

And the backup folder still being Shared -

Thoughts, please.

Hey @xxx,

What is the size of the \\GEIDPRIME\Backups folder?

If you try to copy the folder off the NAS and save it locally, do you see the same no backups found message?

We may need to submit a copy of this folder to QA for further review, but please just let me know the size of the folder (so we can figure out if the transfer can be made via Dropbox / Google Drive or if we need a larger capacity file transfer).

Great minds run in the same channels.

I was, as we speak, zipping up the contents of my backup folder. It’s going to be about 5GB.

Isn’t on a NAS. It’s on a MacMini that is networked. Still, I’ll try the copy.

Everything was good until I did a Restore, a couple of days ago because of my library being corrupted since JUly 9th.

@noris -

I PM’d a DropBox link of the zipped folder.

I inundated you with a lot of screens, but really only three were needed.

Backup says it completed successfully -

Invoking ‘Clean/Restore’ from the very same screen -

Comes back with no backups found -

I checked the folder out on disk and the same number of files are there as before the supposedly successful backup. So, the reason no files are found is because no backup files were created.

OTOH, There were files out there from before I had to restore and all this trouble started. Because my library was corrupted since July 9th, I deleted (from a Roon menu) any files after July 5th. As I recall, there were some backups left that were from before that date.

So, two problems. One is why is backup not writing new files but reporting that the backup was successful and the second is that Restore can’t find any files at all, even previously written ones that I know are there.

This new problem, combined with the backing up of a corrupted library, is truly diabolical.

1 Like

Hi @xxx,

Thanks for your patience while QA has had a chance to investigate your backup report.

After review, QA noted that this issue is occurring due to the fact that one of the backups sub-folder is empty, specifically 5464dd77-00c0-705a-b75f-5c736cfff82c.

Because this folder is empty, Roon could not restore the backup. Perhaps you tried to set up two backups to this directory and there was a structure change to it?

In any case, I would suggest that you remove this folder and create a new one on this location to save the backups.

@noris -

Thanks, but QA’s response completely misses the point.

Roon’s backup told me the backup was successful when it wasn’t or it subsequently couldn’t be found and that’s the real problem here.

So we have a trifecta of Backup problems -

  1. Roon Backup will blithely backup a corrupted library.
  2. Roon Backup will say that it has successfully performed a backup when, in fact, it can’t find the backup it supposedly just successfully performed.
  3. The only way to backup Roon’s library is thru Roon’s Backup, i.e. one can’t use a different software backup program and be assured of a successful restore.

Couple these problems with the fragility of Roon’s database as evidenced by the recent increase in user’s encountering a corrupted library and there is a real festering problem.

I can see by QA’s response to this problem and the original response to the fact that Roon will back up a corrupted database, that there is little interest in addressing these errors.

The first time someone who has invested much time in curating their library runs into problems with a corrupted library that can’t be restored, there will be so much gnashing of teeth that the blow backs about increasing the lifetime subscription rate or the change to the way Roon handles un-certified devices will seem like so many quaint memories.

This problem is not resolved.

As we discussed in my previous PM to you, I have only been waiting to hear that QA has all the information they need before I delete and recreate folder.

Hey @xxx,

Hold on to the folder for now please, me discuss your case with QA on our next call.

QA will probably want to know a bit more about this backup structure, how exactly was this folder created?

Did you try to save backups from two different Cores to that folder location perhaps?

Ha, sorry too late

Hmm, it’s entirely possible that I did. I was running RoonServer on my Core machine, but had two instances of a corrupted library, not to mention music sometimes stopping in the middle of a track, that I started using the complete Roon instead. Since then no problems of that sort. Yeah, I know that doesn’t make any sense, but there it is.

OTOH, everything I did, I did thru the Roon interface.

Really no matter what, the problem still stands that Roon told me that a backup was good and then either didn’t really back up or couldn’t find the backup.

As to the trifecta I mentioned above, let’s hope I am not the canary in the coal mine.

Still, thanks for your continued involvement.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

24 posts were merged into an existing topic: Steps to restore Roon backup and music files to new HDD?

2 posts were split to a new topic: I had backup problems this week