Roon interface volume plus and minus buttons (+/-) sometimes get stuck [Fixed with Build 1364/1365)


have the following problem:

I use a nucleus, music is on a NAS (Synology), and a cambridge audio evo 150 as the output device. Control via Android 12 (cell phone). Software up to date everywhere, including roon.

The following has happened to me twice for about 5 weeks: I start playback via roon, my cambridge turns on, I increase the volume via roon by 3 - 4 points, but suddenly roon automatically increases the volume further, up to 100 % !! When I tried to turn it down again via roon, the volume automatically went up again. When I turned the volume down on the cambridge using the controller on the device, the volume automatically increased again via roon. Had to turn cambridge emergency off or my speakers would be through. It wasn’t until I restarted roon that the volume control was back to normal.

It has happened twice in the last 5 weeks or so. I haven’t changed anything, just updated roon.

Since there is a risk that this will happen again and again and that the speakers will break due to this uncontrolled increase in volume, I ask for your help, I can only imagine that it is a bug.



Possibly related? With a Naim Atom, very similar description:

First suggestion, if possible, is to set a lower max volume on the cambridge audio evo 150. This issue happened to me with my receiver a few years ago and I set a comfortable max limit so no damage would occur the next time. Just protection until the problem is corrected.

What is the volume control in Settings - Audio set to for this device? I believe the options are Fixed or Device.

I’m occasionally having this problem as well. Roon server on an Ubuntu 18.04 machine. Control apps are Android 13 - it’s happened on 2 different phones. Endpoints are RoPieee boxes. It’s happened on 2 different zones. If I try to lower the volume it increases itself right away. Closing the Android app and reopening stops the problem.

Set volume safety limits:

Maybe your Cambridge allows to set somewhat similar limits too? Else, please help Roon Labs to find reproduction steps. Read more about it:

Hey @doro,

Ben here with the support team, I wanted to check in on this thread and see if you’re still running into volume issues after the suggestions listed above? The help article @BlackJack shared is a great resource on next steps.

Let me know if you still need assistance, I’ll be monitoring this thread for your reply :+1:

First of all thanks to everyone for the replies.
So it looks like the problem is with roon as others with other devices are also having the same problem.
I first limited the volume according to BlackJack’s advice. A great tip. Now I also know what this function is good for: To protect my speakers. But honestly, that shouldn’t really be necessary, since the volume shouldn’t become independent. Here it would be good if roon warned its users that this can happen and users should turn on the volume limiter. Otherwise it can get really expensive.

I have read that the support keeps asking how the problem came about with the users. With it was as follows: I selected the music to play via roon. My device was on network standby so roon activated it. When the music was playing, I increased the volume via roon by tapping the plus icon several times. Didn’t put my finger on it. After that, the volume suddenly increased automatically and was unstoppable. Maybe that will help the support.

It would be nice if the problem were fixed, because the volume limit is only a temporary workaround.



I am experiencing this sporadically as well. Happened on 1.8 several times over the last few months and 2.0 happened this morning around 9:15 am eastern.

Using a headless roon core on win 10 HP Elite Desk G2, control via roon on an Samsung S20+ and listening on a Denon AVR-3600H.

The volume slider just starts crawling up to max. Pulling it down works until you let go and it slides up again. I had to stop playing. Close the app and reopened and it was back to normal.

I too have set the max volume to a comfortable level to avoid damaging speakers, but this could potentially blow expensive gear. Can you trust Roon with this kind of error?

I suggest Roon release an update that sets the max volume by default so the owner doesn’t find out the hard way. Make increasing the volume a manual process. Then hopefully, solve the bug. I get that intermittent bugs are some of the hardest to solve, but equipment blowing ones deserve max attention.

When you saw this issue occur, were you using the Samsung S20 remote? Or using some kind of remote access into your Core? If this happens when you were using your Samsung, were you controlling the volume using the hardware buttons or the Roon app buttons or the Roon app slider?

1 Like

I was using the Samsung S20+ as a remote. I’ve only ever seen the problem on the Android remote. Every time I was using the slider. Never the hardware buttons.

Just happened to me (again), at 8PM French time tonight. Scared my baby (and me, as a mater of fact). It has happened before v2, and it just keeps happening randomly.

I use Ropieee or RopieeeXL on Rpi 4B as endpoints for Roon Nucleus, some feed independent DACs some feed AES signal to active monitors directly.

I just tap gently on the volume “+” button of the Roon Android app and there it goes shooting to maximum. Nothing helps to keep it down.

Awful experience garanteed every time. Do I have to open a new thread for this?

Just happened to me again at 9:03 pm wed Sept 28th. Eastern Time. Open Roon on my Galaxy S20, my denon 3600 was already selected. I selected a song and pressed play then went to check the volume while the denon was turning on.

The volume started creeping up on its own. This time I paused the song to avoid waking up the neighbourhood. The volume still crept up. I could turn it up or down using the slider but as soon as I let go it would crawl up faily quickly. I also tried the hardware buttons on the side of the phone and the effect was the same. I could raise the volume even faster or pull it down lower, but as soon as I let go, it starts ticking up quickly again. Nothing would stop it, like changing songs, but closing the app worked. (Hitting the show all apps button, and flicking roon up to close.) Then reopening Roon the volume returned to normal expected behaviour.

Hey @doro, @DrunkyMcStumbles, @MBI and @Greg_Anderson2,

I’d like to dig into this a step further, and request each of you jot down a specific date and time the next time you see this issue happen, as well as test to see if this happens across all your zones/end points. Or, does it only happen on a specific endpoint? Does this happen when using strictly your system output?

With that, could you also please use the directions found here and send over a set of logs from your affected mobile devices to our File Uploader?

Thank you for your patience while we get to the bottom of this issue :pray:

Happened also to me with two different Roon ready devices :rage: nearly crashed my looudspeakers and my ears.
never happened before updating to Roon 2
@Roon: Please fix this dangerous software bug

Then please follow @benjamin 's request above and send logs from your system to Roon Labs. The more data Roon Labs have on this issue the easier it will be for them to diagnose and fix.

1 Like

if you have an iPhone as a Roon Remote, the above work around from @benjamin helped me.

I also have a Samsung M52 on Android 12. Not had this issue with it.

As @BlackJack says, set volume limits in Roon as a safe guard. This is if Roon controls the volume. I have Sonos Fives and in Sonos S2 app I have limited max volume.


Hey @Klaus_Weber,

My apologies here, there is progress being made but we’re still very much investigating the potential root cause of this issue.

A few follow-up questions for you:

  1. What are the specific steps you take to reproduce this issue?
  2. Does this happen on all of your remote devices?
  3. Do you have airplay enabled at all when this issue occurs?
  4. Does this affect specific endpoints? Does the same issue happen when only playing to your system output?

It would be helpful to the team if we could get an updated set of logs from the affected mobile devices as well:

Thanks, Klaus!


I have tried tonight to replicate the issue deliberately. Oddly, it’s doing the opposite now. It lowers the iPhones volume to mute when coming out of the Roon app. I had disabled the automation workaround first though.

I’ll upload the files shortly. Will try again to replicate the maxing out issue.

1 Like

My log files for both experiences have been submitted. I’ve labelled them mute and max to identify them.

However, the issue of the music volume hitting max after exiting and entering the Roon app and adjusting the musics volume isn’t happening now for me.

1 Like

Dear Ben,

  1. Started Roon again a few mibutes later.
  2. Only used my iPhone
  3. no
  4. two endpoints, Mytek BB and Lyngdorf TDAI 3400

As I don‘t want to damage my ears and my loudspeakers I will not use Roon as long as this dangerous bug isn‘t fixed.

kind regards

1 Like