DSD512 with micoRendu NAA App and Holo Spring DAC [Solved, Managed switch, Flow control]


I hope you don’t mind me contacting you, but I am having difficulty getting DSD512 playback in my setup and I was hoping you could help. You seem to be having success with a setup very similar to mine. I am also using the NAA app via microRendu, Holo Audio DAC and a PC (i7-7700K, Nvidia GTX1070). However, when I attempt to output DSD512 - the song plays back, but the speed is too slow. For example, it takes 1 minute to play about 56 seconds of the song. I’ve tried using both DOP and Native playback.

If you could share your settings in HQPlayer, microRendu, Roon and any relevant settings elsewhere, I would greatly appreciate it.


Hi Antony,

I heard something similar once when I think I was using a closed-form filter with a Hi Res file and selecting a Bit Rate which was not an even multiple of the original sampling rate. I power cycled everything (fancy talk for turning off, wait 10s, turn on again) and it came right.

Roon is just a standard localhost HQP Network zone. No changes to default settings.

Screenshot of HQP Settings:

The mR has the NAA selected; no Settings available.

The Spring is USB input and NOS.

Let me know if that helps, if not we’ll get Support involved.

I’m using native DSD (SDM Pack = None in HQP) and there is a nasty full volume POP whenever I start Play or FFwd. I work around it by Adding Next or Adding to Queue rather than Play Now. Or I mute the preamp before Play Now. The poly-sinc-shrt-mp filter can take up to 10s to initialise; I wait to unmute until I see the Processing speed in the Signal Path pop up, that appears when the music starts.

One possible explanation for the POP is some bad code in ALSA (they sent PCM silence instead of DSD silence). It has been fixed in the 4.10 Linux kernel. Dan Knight has incorporated the fix in DietPi. Still waiting to see if kernel 4.10 fixes it for the mR.

Let me know how you go.




Thank you so much for the reply.

I updated my Settings to match yours and I still had issues with playback. When I set SDM Pack = None, playback appears to be at the proper speed, but is choppy. The sound was cutting out every few seconds. I modified some of the SDM Defaults and was able to get better performance, sometimes it would work fine for a couple of minutes, but invariably the dropouts would return.

At this point, I’m confused as to why it won’t consistently work. My PC should be powerful enough to run DSD512. Maybe it’s my network as I stream to the device via a Powerline Adapter as I can’t wire directly to my switch. However, with that same Powerline Adapter / Switch combination, I can stream 4K material from both Amazon and Netflix without issue.

Any advice or help would be greatly appreciated? I noticed that Roon reports the Processing speed during playback when you select to view the playback chain. Does the Processing provide any insight?


RAAT uses multicast and UDP as well as TCP. Anything that interferes with those protocols will cause problems.

I’m no network engineer. At this point I’d suggest opening a Support thread. Are you happy for me to convert this into one ?


Hi Andy,

That would be great - please open the Support thread.

Thank you for all your help.


Dropping a flag for @support.

Over the years, we’ve seen tons of issues with powerline adapters (even when streaming 16/44.1 content) that are resolved as soon normal gigabit ethernet is used.

The two most likely culprits here are probably going to be the power of the machine doing the upsampling, and the network. If you’re pretty confident your machine isn’t underpowered, experimenting with the network and testing temporarily with standard ethernet are probably the next step here.

1 Like

I got it to work last night. The issue was related to my network. After I moved the Ethernet cable output of my Powerline adapter from my Netgear switch to the microRendu directly, playback was fine. Any ideas as to why the switch is causing an issue? Are there settings I can change since it is a Web Managed switch? I would like to keep the switch in the chain as I have other devices that need to be connected to my network at that location.

After I removed the switch, the only playback issue I had was when I tried to run one of the new xtr filters. HQPlayer seemed to lockup. I may have abandoned it too early as I read later on that it can take several minutes to initialize. I may give it a shot again over the weekend.

Things that a switch might be doing that could upset RAAT include having jumbo frames activated or limiting multicast or UDP.

Can you describe the model of Netgear switch and how it is configured ?

Enabling flow control on managed switches has helped others.

1 Like

I was able to fix the issue by Enabling Flow Control as you suggested - thank you.

I’m not really sure what it does as the setting defaults to Off for all of the ports on my switch. Should I enable it for all ports or is it helpful just for Roon / HQPlayer?

I don’t really know. This is what Wikipedia says about flow control. I’d be inclined to leave it on the default setting except where it is needed.

I think it would be a huge help to have information about enabling flow control in the knowledge base. I ran into this exact issue today and it took a bit of searching before I came upon the solution.

1 Like